DataMapper ORM

Server Requirements


Using PHP older than 5.1.2

It is possible, by manually modifying the DataMapper library, to get Datamapper ORM to work on PHP older than 5.1.2. PHP 5.0.0 or newer is still required, and it is not officially supported.

Please see this forum post for instructions.

CodeIgniter 2.0

Datamapper is tested with the latest CodeIgniter 2.0 (which has not yet been released at this time) from the Bitbucket repository and is proven to work.

However, until it is released, we can not guarantee it will work with any particular development version.

Expression Engine

Please note: Expression Engine is not officially supported.

Patches and suggestions are welcome, however.

Using Oracle

Oracle probably will not work 100% out-of-the-box.

However, Frank Liu has done some research on how to get Oracle working.